続けてiozone

-t オプションをつけて実施してみた。

% iozone -t 2 -s 200M -r 128K -i 0 -i 1

結果は

	Children see throughput for  2 initial writers 	=   28340.63 KB/sec
	Parent sees throughput for  2 initial writers 	=   27582.50 KB/sec
	Min throughput per process 			=   14149.03 KB/sec 
	Max throughput per process 			=   14191.60 KB/sec
	Avg throughput per process 			=   14170.31 KB/sec
	Min xfer 					=  204160.00 KB

... 略
	Children see throughput for  2 readers 		= 1808282.81 KB/sec
	Parent sees throughput for  2 readers 		= 1707395.39 KB/sec
	Min throughput per process 			=  899752.31 KB/sec 
	Max throughput per process 			=  908530.50 KB/sec
	Avg throughput per process 			=  904141.41 KB/sec
	Min xfer 					=  186496.00 KB

Writeはこんなものかな。。。ファイルサイズを大きくしても変わらずだし。
Readは異常な数値だな。。

とあるVPSでも実施してみた。

Command line used: iozone -t 2 -s 1G -r 16M -i 0 -i 1
...

	Children see throughput for  2 initial writers 	=  121388.65 KB/sec
	Parent sees throughput for  2 initial writers 	=   31511.61 KB/sec
	Min throughput per process 			=   60125.28 KB/sec 
	Max throughput per process 			=   61263.37 KB/sec
	Avg throughput per process 			=   60694.33 KB/sec
	Min xfer 					= 1032192.00 KB
...略
	Children see throughput for  2 readers 		= 1074459.62 KB/sec
	Parent sees throughput for  2 readers 		= 1044948.72 KB/sec
	Min throughput per process 			=  527165.88 KB/sec 
	Max throughput per process 			=  547293.75 KB/sec
	Avg throughput per process 			=  537229.81 KB/sec
	Min xfer 					= 1015808.00 KB

かなり速い。。。
使っていると速いとは思わないんだがな。。。
iozoneの使い方がよくないのかな。。。

 

なんとなくiozone

ESXi上のFreeBSDでiozoneを実行してみた。

% iozone -g 2g -i 0 -i 1 -Rab excelfile

エクセルファイルに出力してグラフ化してみた。
■Write Report

■Read Report

速すぎる。。。なんか怪しい。。。

■Write Report (32MB以上のデータ)

これくらいが適正か。。。?

■Read Report(32MB以上のデータ)

これも怪しい。。。

 

Intel AMT v7

Intel AMTなんて初めて知ったのですが、HPのiLOみたいなものなのね。

さっそくBIOSから設定する。Intel MEを選択してパスワードを入力。
defaultはadminで設定されている。パスワード変更後、各種設定ができます。

Remote Serverの設定を訳も分からず設定してはまる。。
1台だけ管理するにはこれは必要なさそうです。よく調べてません。
Intel MEでdefault設定に戻して再度挑戦。(passwordは変更されたままなので注意。)

Local Serverの設定を実施。
IPアドレスなどの情報を設定して終了。
※以前はVLANの設定もできたようですが、v7では設定画面がありません!なんで?
これは困った。。。ESXiで.1Q設定しているんだよ。。
#解決策がないでもないが、ESXiおよびSWの設定変更が面倒なのでサポートされるまで待つ事にする。vlan設定が復活するのかは不明だが。

とりあえず、.1Q設定していないSWのportへ接続変更して、
http://IPaddress:16992 でuser:admin passwordを入力しするとwebページで設定できる画面が表示されます。とりあえず確認のみ。
他にも調べる項目はあるけれど、VLAN設定ができないのを知り、テンション下がったのでおしまいにする。

うーん。VLAN設定がなくなっているのはとにかく痛い。。。。

 

DQ67EP + i5 2400S買ったけど。。

簡単に仕様を見て、DQ67EPを買ったのですが。。。
Mini-ITX, RAID, Intel NIC, 管理とあったのでこれならESXiも簡単に動くだろうと
思ったのが甘かった。
CPUも低電力だし、VT-dもあるし。。。いろいろ楽しめそうだと思ったのに。

PC組み立て終わって、ESXiインストールだ!と思って、CDからインストールすると
起動しねぇ。。。(まずはRAIDとか組まずにノーマルに動くかテストのつもりだった)
ESXiは相性があるみたいなので、いろいろ調べてると。。。
NICが対応してないじゃないか! Intel 82579LMというコントローラはサポートしていない。。。
RAIDも組んでHDDブートですっきりさせるつもりが、あえなく野望がくずれた。
USBブートの道を歩む事に。。。
(IntelのMBじゃなくてもよかったじゃないか。。USBブートするなら、FoxConnのH67とか安いものでも良かった。。。)

google先生に尋ねたところ。。。
(参考)
メモメモ。。。

■ 手順
 1.Explzhを使って、ESXiのisoイメージからimagedd.bz2ファイルを取り出す
 2.Lhaplusでimagedd.bz2を解凍しimageddを取り出す
 3.WinImageでimageddのoem.tgzを上書き
 4.DDforWindowsでimageddをUSB diskに書き込み

USB bootすると、問題なくNICを認識しました。datastoreが2個作って、
Diskも問題なし。

さて、次にRAIDの設定を。。。。(ここでも野望が崩れる。。。)
Diskを3.5インチ2本買ったし、RAID1にして、すこし安心できるかと思って、いろいろ設定しようとしたがうまくいかない。
BIOSのSATA driveの設定でAHCIからRAIDに変更。rebootして設定しようと思ったら、画面の切り替わりが早過ぎてどのキーでメニューに入れるのかわからない。。
なんどかrebootをして、CTL-I (コントロール+大文字アイ)を読み取った。
何度かCTL-Iを連打してようやくメニュー画面へ。(なかなか割り込んでくれない)

Vol0などとVolume名を作ってRAID1を構成してみたものの。。。

ESXiをbootしてvSphere Clientからストレージを見ると、物理デバイス2つ見えたまま。。。
ん? どういうことだ。。。Intel Rapid Storage Technologyってのは普通のRAID controllerとは違うのか? (要調査)

biosも新しいのが出ていたので、バージョンアップしても変わらず。(0041 -> 0051)

とりあえず、RAIDを壊して、BIOSをAHCIに戻して、datastoreを2つにして環境構築。(PCケース小さくてよかった。電源もSFXでよかった。。MBもIntelじゃなくてよかった。。。とほほ。。。。)

ここまで来たらあとは通常のESXiでの作業。A-Openのサーバからインスタンスをssh経由でコピーして、データストアの参照からインベントリに追加して完了。
sshでコピーする際に、-c オプションで暗号化を軽いものにしようとしたらオプション無視された。。。ひどい。18MB/sec(128Mbps)くらいの転送速度。

mp3をUSBディスクに入れてたので、これを機にインスタンス側でdiskを追加してそちらに完全移行。これでコンセントも1つ解放。

 

サーバリプレイス

さてGWに突入しました。GW直前は多忙で検証したいものがいくつかがあったのですが、自宅のサーバが非力で限界。。。
検証もできずストレスフルでした。そんな訳で自宅のサーバをリプレイスします。
ESXiを載せます。
自作なんてしないんだけど、小さくていいものがなかったので仕方なくチョイスすることになりました。電源まわりとかよくわかってない。。

PCケース: abee acubic M20 (仕様)
MB: Intel DQ67EP B3 (Mini-ITX)
CPU: Intel Core i-5 2400S (Sandy Bridge世代)
Mem: Patriot DDR3 8GB (2 x 4GB) PC3-10600 (1333MHz)
HDD: Western Digital WD20EARS SATA 2TB (2個)
電源: 剛力短2 500W

■PCケース

現在のA-Openに比べるとかなり大きい。3.5インチDiskを2本積みたかっただけ。
CD-ROMとか使わないので、5インチベイをつぶして追加の3.5インチディスクを
載せます。
(M10でも良かった気もする。。。なぜならRAIDにできてないから。。。1本で良かった。)

■MB (DQ67EP)

Intelでなくても良かったんだけど、ESXiインストールするので、IntelのNICを
追加購入するくらいならとIntelを選択。
グラフィック系は使わないし、HDMIとかいらないし、管理系の機能(AMT?)が
あるみたいなので、Q67系のボードを選択。
※あとで気づいたのですが、NICがIntel 82579LMコントローラ。
なんと、これはESXiでサポート外。。。oem.tgzで対応が必要だった。。。Orz.

■CPU(i5 2400S)

このCPUはTDPが65W。
i5 2500TはTDPが45Wなので、こちらが欲しかったのですが、どこも売ってません。

■電源

筐体ないの占有場所を考え、剛力短2を選択。500Wも要らない。。。
やっぱり、M10のケースで充分だった。。。300Wで充分だよね。